Alarm Countdown not functioning

Store Forums Defusable Clock Bugs/Problems Alarm Countdown not functioning

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #406

    When I press the detonate button, the clock immediately lights up and makes noise. There is no countdown from 10 – 1. The alarm clock is in defuse mode (I tried it in all others just in case). Everything else is functioning, I can change the time, etc. Sound and all LED’s are working. Double checked my solder, went over everything. I paid special attention to the chips, as that is where I assume this function would be located. Any idea where I should focus my efforts?


    I had this problem the first time I turned mine on. Make sure all the wires are screwed in all the way. Remember, the wires go On top of the metal thing in the terminal. Unscrew the terminal all the way and then put the wire in to make sure it is oriented correctly. If it still doesn’t work, try different scissors if you cut it. Sometimes the scissors themselves conduct electricity and trip the “wrong wire cut” circuit.

    Hope this helps 🙂


    It works exactly as you said, but after one beep it stopped working and not started after that.

    achat immobilier


    JackSmith, did you connect the wires? If it beeps once and stops then it is “defused”, so you need to connect 4 wires from the left terminal blocks to the right terminal blocks.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.