Another shorted supply – post regulator

Store Forums Defusable Clock Bugs/Problems Another shorted supply – post regulator

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #572
    jstein
    Member

    Hi there,

    I bought my 11 year-old the defuseable clock kit as his first foray into soldering. He assembled it yesterday under my watchful eye (I am an experienced solderer). When he connected the board up to a 9V wall-wart, nothing appeared on the display and he noticed that the regulator was getting very warm.

    I immediately pulled the power and brought the board into work to check the soldering under a bench-top microscope. Except for a few messy joints, I couldn’t find any damning evidence of a problem. We have checked and double-checked the IC orientation.

    After touching up a few cold joints, I cleaned the board and then attached to a bench supply @ 9Vdc; when I turned it on the supply went into current limiting mode @ 1A; so I shut it off.

    I then removed the Arduino and tried powering up; again – 1A draw.

    Any more ideas? I’m sad that my son’s first experience is not as pleasant as mine when I was his age building Heathkits and looking for any solution.

    Thanks!
    –J

    #915
    Michael
    Keymaster

    Sorry to hear that. The only idea I have is to carefully check the solder joints marked red in the diagram in this thread:

    http://nootropicdesign.com/forum/viewtopic.php?f=34&t=2486

    The most likely cause is that one of these joints is shorted against the ground plane (which is the bottom of the board). Several customers have found that problem and fixed it by removing excess solder from one of these joints.

    If that doesn’t help, I’m happy to replace the kit. Just keep me informed.

    • This reply was modified 5 years, 7 months ago by Michael.
    • This reply was modified 5 years, 7 months ago by Michael.
    #916
    jstein
    Member

    Thanks for the quick reply! – I will check those solder connections at work tomorrow.

    #917
    jstein
    Member

    Success! (Kinda…)

    I first measured the resistance between the VCC and GND pins of the LED driver (pins 16 and 8 ) and found it was a dead short – which explains why that poor regulator got so hot.

    After closer inspection in and around certain pins, I discovered at the 10K resistor located near the Alarm pushbutton. It looks as if my son may have inadvertently gouged some of the bottom mask and exposed the ground plane below. I re-soldered the one side of the resistor and measured the two pins as above – no more short circuit!

    I then plugged in the supply and basked in the glory of glowing red digits….

    except 🙁

    Not all of them display – specifically the tens place for minutes does not work, nor does the PM indicator LED. The functionality seems to work fine – I was able to detonate the device with the red button and all the LEDS worked at that point.

    I suspect my son may have done more damage than just that one section near the 10K resistor.

    Would it be possible for me to buy another unit? I’ll assemble it myself and tell him I fixed his at work 😉

    #918
    Michael
    Keymaster

    I’m glad you found the short. I think you might be able to fix the digit 3 problem (third digit from left). In the image below I marked the connections associated with that digit. I think one of them has a bad connection. If you reheat each of them, you may just fix the problem.

    The PM indicator is only supposed to illuminate when you are actually setting the time (and the time is PM). It does not stay on during normal operation because it’s too bright and annoying. If it lit up during detonation, then the connections are good.

    If a multimeter shows that there is a bad trace on the board, then I will gladly replace the kit.

    Of course you can buy a new kit from the store if you can’t fix your problem. I have an 11 year old son myself, so I totally know where you’re coming from. ;D My son isn’t interested (yet) in electronics, though!

    -Michael

    #919
    jstein
    Member

    Success x 2!

    You narrowed it down nicely Michael, there was a small bridge of solder on the collector lead of the right-most transistor, shorting that side to the ground plane. This was not a section which my son had gouged accidentally however, so I had passed it over quickly on initial inspection.

    It seems as if the board house who created your boards may have not gone far enough with their mask? I see how there is exposed areas of the ground plane near many of the pads – easily bridged by improper (or sloppy) soldering technique.

    I also found the exact same thing on the PM LED (which, it turns out, was NOT lighting during the “detonation”); after cleaning both issues, the clock works quite nicely.

    Thank you for your support! I would be interested in purchasing another version of this kit in the future if and when the solder mask / ground plane issues are made a bit more “kid proof”.

    –josh

    #920
    Michael
    Keymaster

    That’s good news. Sounds like there were some solder mask gaps on your board, sorry about that. I’ve used the same board house for several years on all my products, and have only had a handful of problems (of thousands of boards manufactured). I’ve inspected quite a few boards and only found one case of a ground plane exposed near a pad. Hope you and your son enjoy the clock!

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.