Cannot Program Lumazoid with Arduino IDE

Store Forums Lumazoid Bugs/Problems Cannot Program Lumazoid with Arduino IDE

This topic contains 3 replies, has 2 voices, and was last updated by  Michael 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #9594

    AndrewW2
    Participant

    Hi,
    I just need to tweak the colour choices on the Lumazoid and want to download a new program. I don’t have the Adafruit FDTI board but I have a similar board that appears almost identical (it has DTR and not RTS on the default header but I have picked up RTS from another pin and got arond that issue just in case).
    I’ve set device as “Arduino / Genuine UNO” and “COM3” happily pops up in windows and the IDE but the upload fails with various:

    avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x67

    The resp code varies a little (don’t know why).

    All searches on this type of error suggest there is no bootstrap loader or other cabling issues. Any ideas what I could be doingwrong?

    Thanks.

    Andrew.

    #9595

    Michael
    Keymaster

    Make sure that the 5V power is connected as well as the FTDI adapter. In order to prevent the LEDs from drawing too much power from the FTDI adapter, the power 5V line from the adapter is not connected to the power of the Lumazoid, so you also need to have the main power connected.

    (Sorry, I need to make that more clear in instructions.)

    If you want, there is a jumper on the back of the board that you can solder so that the 5V line from the FTDI adapter IS connected to the Lumazoid.

    #9598

    AndrewW2
    Participant

    Michael,

    Yep that was it. I was fooled by the blue LED illuminating into thinking the FTDI borad was powering the Lumazoid. I reconnected my 5v supply and making sure my FTDI was using RTS and not DTR it successfully reprogrammed.

    Thanks for a great product and equaly great support. Also thanks for making the code open source.

    Andrew.

    #9600

    Michael
    Keymaster

    Awesome!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.