Cant get librarys to work

Store Forums Video Experimenter Bugs/Problems Cant get librarys to work

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #14372
    mail@aaronlord.com
    Participant

    Hi am trying to capture with the VE board. I have tried to install the TVout-ve library and am having problems as library.properties files were not found. These a\re needed in the new library spec. I have copied the files from TVout (non ve) and the library now imports. However I am now getting an error saying class TVout has no member named capture (resume also). can anyone help please. Does anyone have a copy of TVout-ve that works with the new specifications?

    #14373
    Michael
    Keymaster

    You can install the library by just dropping the TVout folder in your Arduino libraries folder. The library.properties file is not required by Arduino to use a library. Make sure you do not have the original TVout library installed there. Your error indicates it is finding the original TVout.

    So, in Arduino/libraries:

    
    TVout
    ├── TVout.cpp
    ├── TVout.h
    ├── TVoutPrint.cpp
    ├── examples
    │   ├── ClosedCaptions
    │   ├── DemoNTSC
    │   ├── DemoPAL
    │   ├── EdgeDetection
    │   ├── ExtractCaptionWords
    │   ├── NTSCserialTerm
    │   ├── ObjectTracking
    │   ├── OverlayDemo
    │   ├── TVBlaster
    │   ├── VideoFrameCapture
    │   └── VideoMIDI
    ├── keywords.txt
    ├── spec
    │   ├── asm_macros.h
    │   ├── hardware_setup.h
    │   └── video_properties.h
    ├── version\ history.txt
    ├── video_gen.cpp
    └── video_gen.h
    

    (sorry, this library is over 10 years old, long before the newer specs)

    • This reply was modified 2 weeks, 1 day ago by Michael.
    #14381
    mail@aaronlord.com
    Participant

    I have tried this. It just comes up with invalid library when I try to use it.
    any ideas?

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.