Countdown Problems

Store Forums Defusable Clock Bugs/Problems Countdown Problems

This topic contains 5 replies, has 2 voices, and was last updated by  Michael 4 years, 5 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #763

    Kogoro Mouri
    Member

    Hello,

    the defusable clock was working fine many time, but now, i have a problem, i can now only change the countdown timer by pressing the “alarm” button and, when i set the countdown, when it reach 0:00 it make nothing and continue coutndown with 10:00 minutes, i have tried to resend firmware (i have the cable and the firmware V2.0 ) and after that, set countdown have the same problem (can only set countdown by pressing alarm button) and after reach 0:00 in countdown it continue countdown with 10 minutes, it never stopping the countdown (exept if i cut the good cable or if i cut wrong cable (detonate)

    it is normal or i am dumb and its a part of the new firmware programation to “Loop” the countdown ?

    i read is a simila problem as this post: viewtopic.php?f=34&t=2914

    But mine loop the countdown when reach 0:00 (make infinity countdown)

    EDIT: i have checked (visual) the circuit and i doesnt find any problems, scratch or bad connection.

    #2232

    Michael
    Keymaster

    Try this factory reset procedure: hold down the HOUR and MIN buttons while powering on the device. This will erase the EEPROM, which I think is corrupted somehow.

    Attached is firmware with the factory reset procedure. I will update the version on the download page tonight.

    #2233

    Kogoro Mouri
    Member

    Hello, i have tried this, but it seem change nothing, normally when reset or install new firmware, it will “Reset” the custom coutdown (e: i have set 0:05 Seconds) normally, if i reset or update firmware, it will be set default countdown?

    If i try reset or firmware uploading its doesent change anything, after 5 seconds countdown end, it restart countdown (now at an another number)

    #2234

    Michael
    Keymaster

    I updated my post to attach firmware with the factory reset procedure. Please try the firmware attached above. (The code on the web site does not yet have the reset procedure.)

    #2235

    Kogoro Mouri
    Member

    Hello, Thanks for this updated firmware, it have fully resolve my problems, it’s now working fine as when i have bought them 🙂

    #2237

    Michael
    Keymaster

    Perfect!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.