Magic smoke: repairable?

Store Forums Hackvision Bugs/Problems Magic smoke: repairable?

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #14281

    A couple of years ago I picked up a Hackvision v2 kit, then forgot about it in a box of arduinos – until today! I had a lot of fun soldering it up, it’s such a cool kit.

    But then I then plugged in a 9v 1.67A power adapter and magic smoke came out. After checking my adapter, I realized it had a reversible tip – and it was set to negative, not positive. Oops.

    Now I’m kind of hoping to figure out what I blew up. I don’t know what I’m doing, but I took a multimeter to see if I could measure any obviously dead things. Everywhere on the board that has “ground” and “5v” are all still showing the correct 5v (even the microcontroller).

    I don’t really know how to measure anything else – but every component is still showing non-zero voltages (even the voltage controller). My guess then is it’s the microcontroller that is fried?

    Anyway, if you have any advice on things I should test with a multimeter (I don’t have an oscilloscope), and values I might expect… or even if you could point me towards any good learning resources that would cool!


    It’s likely that the voltage regulator got fried but maybe not. It’s very likely that the microcontroller got fried. Hard to test the microcontroller. Good news is that it can be replaced because it’s in a socket.

    Are you in the U.S.?


    Hey Michael – no, I’m in Australia (I got the kit when I was in the US though. (also also, yes, I bridged the PAL connection)). I’m not really too fussed about fixing this, so don’t worry too much. It was fun to solder it up, and to do some troubleshooting – great learning experience!

    After pushing a multimeter around the board and not seeing anything crazy, I thought it must be the microcontroller. I have an EEPROM burner so I read the chip. It successfully pulled everything off it (and could see the menu strings etc in the dump). I then wondered if maybe some garbage got written… I compiled and converted the output to a bin file and wrote it back.

    I was pretty surprised when the sound worked when powered on! Also, my TV was going crazy trying to get the composite video signal. Before there was absolutely nothing. Now it was flashing “NO SIGNAL” then off, as it acquired/lost the signal. Every once-in-a-while I get a frame of a picture too! Not the correct game graphics, but some black and white lines (I tried it on a couple of TVs and a VCR, but no luck.).

    I wondered if something on the microcontroller was still damaged, so I dug up an old Arduino and tried the ATmega328-PU chip from that. It was exactly the same: sound works fine (and I can hear the sfx as I invisibly play the game on the controller) but the video only shows a frame once-in-a-while.

    I’m kind of intrigued about what I did: the smoke must have come from somewhere, so I guess *something* is only partly working. But it’s weird that it seems like the game and sound is working correctly. I’m pretty sure all the solder joints are good and no shorts, but I might be wrong!

    I think my next step is to pull out the components one-by-one and test them and resolder them.


    Well, lol… I replaced every resistor, capacitor, diode, voltage regulator (and a couple of them did seem dead)… but new components, and exactly the same result: sound (and I think game play) works, video never syncs – just keeps stuttering/flashing no-signal as it tries to display it. Occasionally see a black screen with glitchy lines.

    Perhaps I damaged the board somehow, but I think I’ll put this in the “too hard” basket until my electronics knowledge improves!

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.