Not working – HELP

Store Forums Defusable Clock Bugs/Problems Not working – HELP

This topic contains 4 replies, has 2 voices, and was last updated by  Michael 4 years, 5 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #762

    Jzemire
    Member

    Hello, so I bought the Defuse a Bomb clock all assembled with the 7 brown papered looking pipes. Brought it home, I plugged the usb charging cord into a power outlet, and then into the unit itself. But whenever I plug in the battery while the charging cord is plugged in it turns off. How am I supposed to charge the battery then? Also when ever I try to raise the defuse time from 10, by “Holding” the DET button, I hold it and it starts to count down before I release, with out letting me press any of the hour/minutes buttons to adjust it. What do I do?????

    #2222

    Michael
    Keymaster

    We do not sell a product with brown papered pipes or a USB charging cord. Are you sure it is a nootropic design product? Does the circuit board say “nootropic design”? Can you post a picture?

    #2220

    Jzemire
    Member


    This is the one I have. I sorted out the first issue. Now only the second issue remains. When I hold down the DET button the countdown sequence initiates with out releasing the DET button. I’m unable to figure out how to adjust the countdown timer now. If I try holding it down it starts immediately, and once it does none of the other buttons do anything until it “detonates”

    #2223

    Jzemire
    Member

    This is the one I have that I just took a picture of

    #2224

    Michael
    Keymaster

    That device is NOT the nootropic design Defusable Clock. That is a cheap Chinese counterfeit. You bought a fake.

    Look closely at it — it is not the same. Here is the REAL product. Look at the difference in quality.

    Where did you buy it? Was it advertised as the nootropic design Defusable Clock?

    If it does not work, you should return it.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.