‘TVout’ does not name a type

Store Forums Video Experimenter Bugs/Problems ‘TVout’ does not name a type

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #530

    First off using mac. Anyone run the overlay demo on a mac successfully?
    Tried installing different libraries and then running the Overlay Demo that came with that library.
    TVout_R5.91 , TVout-VE , TVoutBeta1 , and TVout
    ‘TVout’ does not name a type’ comes up almost everytime during compile.
    Got past that one time to get NTSC out of scope.

    One compiled a week or so ago and was able to get printing on the video screen. That printing was all by itself in that it didn’t overlay the input video. Might have been sync only mode just to try and get anything to happen.
    The Overlay Demo hasn’t worked yet nor has anything ever overlaid the input video.

    Any ideas would be appreciated.

    Which TVout would you expect to work for overlay?
    Using an ATmega328
    Import Library method is, Right click Arduino app to show the package contents, in resources folder there is the Java folder. In the Java folder is the Libraries folder. Downloaded and unzipped TVoutxxx file is put in the Libraries folder. Folder renamed to get rid of -VE, _R5.91, ect.
    TVout shows in the Sketch-Import Library dropdown menu.
    Installing Libraries in this method has worked for the Ultrasonic library for example although its name wasn’t modified.

    Should I do it on a PC instead? XP or 7?



    So this seems to be a library problem. The TVout.h file cannot be found. It is where it should be in comparison to the other libraries but still says No such file or directory.

    I’ll go and try it on the PC side


    I don’t know what the problem is. Please know that I use a Mac for all development!

    Install libraries in your sketchbook, not the arduino app’s package contents. This is a folder named “libraries” in your sketchbook folder. Only have ONE version of tvout installed…the VE version of course.

    Don’t mess with importing the library in the IDE …the demo sketches will compile as-is. In other words, the library is already “imported” which is the Arduino terminology for adding the #include statement.

    I know there’s nothing wrong with the library because hundreds of people are using it…


    Thanks for the reply Michael. The problem on the Mac side is my own. Getting the Library installed correctly on the Mac has been my problem. The good news is I did get an overlay on live video from a CCTV color camera using a PC to upload to the arduino.
    Putting overlay info on security DVRs is my goal.
    My new problem is the demos have horiz and vert sync problems on the three different displays I tried. Thats assuming the sync problem is from the display. Two different inputs have been used one from the CCTV camera and one from the output of the security DVR. Any suggestions or sites that you might point me at would be appreciated.
    Thanks again


    Can you describe the problem in detail?


    There are two overlay demos. There is one that is part of the library TVout-VE called DemoNTSC and there is the overlay demo on the Video Experimenter page of the Nootropic website. So the one from the library (DemoNTSC) has text that is scrolling down the screen but moving left or right very quickly. It is hard to describe since I have never seen what it is supposed to look like. It might be easier to tell you that the 3D image produces a line of objects that move left to right so fast as to produce one and slowly from top to bottom. If this is one 3D object it is being printed maybe 10 times from side to side to make a strip that moves from top to bottom in about ten seconds. the words at the beginning also fill the screen from side to side and scroll from top to bottom at the same pace as the 3d image(s).
    the other demo is the one that is shown all over the web with the milliseconds? showing time, The graph, and “overlay text and video . . .”
    This one reacts a bit differently. Everything that is supposed to overlay has been pushed up almost a quarter of the screen. Everything nearly stays put but doubles up left to right so there are two graphs for example. The time is pushed up so far you can only see the very bottom of the numbers. The scrolling words in this demo can be seen and read.
    Hard to describe but the two react quite differently in that the DemoNTSC makes the words totally unreadable with this fast movement from one side to the other. It is like horizontal roll that creates duplication across the entire screen. The other demo looks like the overlay is too big for the screen so it is doubling up horizontally. Jeez, Sorry to be taking your time on this.
    As far as the library thing goes, The way you described is the way the instructions go. I have tried this many times, just tried again today. I cannot get a folder named sketch to save my life and have tried many different ways. Today I was shown a folder when I asked to see the sketch folder. It was the folder with the name of one of my projects. So a sketch folder was made in the same folder as the found folder. Not recognized as the sketch folder. Quit and restart app. No joy. Go to preferences and put Sketch folder in sketchbook location. No change. Quit and restart app. No change. Rename the folder that it says it is the Sketch folder to Sketch. That blew its mind and now when asked where the sketch folder is I get this Path;
    Macintosh HD/private/var/folders/o6/o6sts3inFlubAHsC4wyH/-Tmp-/untitled162759080553/sketch_jun30a.
    and No, I don’t let web pages tell me “You have a virus and should install this software now!” :). It’s getting funny now. I’ve used Macs since they only used floppy discs because I thought they were easier! It is embarrassing to say how much time was spent with this Sketch thing to try and install a library. I thought I had found a way that worked. Like I said the Ultrasound Library installed just fine and the example sketches are even in the Examples of the File menu
    None of this is anyone’s problem but my own. Just wanted you to know I am really trying before asking. I will try installing on a different mac while following the instructions step by step.
    Thanks for your time


    The demontsc sketch is not for overlay. It came with the original tvout.

    What is your sync select jumper set to? It should be on “input”.

    I don’t know why you are aren’t this doubling. Are you in an NTSC or pal country? If pal, then you need to modify the code to init tvout with pal.

    Ok, I’m very confused about why you are trying to create a folder named “Sketch”.

    The folder that has your projects is called you sketchbook folder. It ISN’T named that. That’s just what we call it.

    In this folder, at the same level as your projects, create folder “libraries”. Dont use the Arduino IDE to create it– just use Finder.
    Install you libraries here.


    Also, have you adjusted the R4 potentiometer? It should be at a very low setting.

    I’ll be able to support you easier next week. I’m on vacation in London and am typing on an iPod which is maddening…


    Hi Michael,

    First off, enjoy your vacation! Looking forward to you getting back so you can ship the Digit Shield ordered yesterday.
    So, I was going to get a screen grab of what the demo looked like to put in the email. Easiest way for me to get video on the Mac is through the Slingbox. Opened that up just a moment ago and the video was being overlaid perfectly!
    Now my messages prove that just about anyone can get your board to overlay video. If a guy who can’t even install a library can do it!

    Went back the other night and read many messages about installing libraries and did realize that the folder name was not important. Haven’t set it up to work yet but that’s next.

    Thanks for your patience and replies


    That’s very good to hear, and your new Digit Shield will ship on the 5th!

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.