TVOUT driving me nuts…

Store Forums Hackvision Bugs/Problems TVOUT driving me nuts…

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #686

    Hi All,

    I have a Hackvision and am using Arduino 1.05 on OS X. I am trying to install the standalone space invaders that Michael wrote. Per the games page on Nootropic Design, it requires the google tvoutbeta1 library.

    I have tried several ways of installing this library:
    unzip and use the IDE to install the library, unzip and copy contents of fonts and pollserial into tvout folder then import via the IDE.

    I hit the rest button (or not, same result) on the HV, click compile and get a large error log, here is the first section:

    SpaceInvaders.ino: In function ‘void gameOver()’:
    SpaceInvaders:279: error: invalid conversion from ‘const unsigned char*’ to ‘uint8_t’
    SpaceInvaders:279: error: initializing argument 1 of ‘void TVout::select_font(uint8_t)’
    SpaceInvaders:281: error: ‘class TVout’ has no member named ‘print’
    SpaceInvaders:283: error: ‘class TVout’ has no member named ‘print’
    SpaceInvaders.ino: In function ‘void enterInitials()’:

    I am using the HV to teach my son about bitmaps (maybe get him interested in programming) but there is something I am missing. If one of you has time caould you give me some pointers.

    Much appreciated.



    These 3 directories should be in your Arduino sketchbook libraries folder:


    They are peers of one another. They are separate libraries.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.