FTDI must be unplugged every time to upload sketch

Store Forums RGB Matrix Backpack Bugs/Problems FTDI must be unplugged every time to upload sketch

This topic contains 3 replies, has 2 voices, and was last updated by  Michael 3 years, 7 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #798

    sockbot
    Member

    I am having a problem where my backpack won’t accept a sketch unless I unplug both power and the FTDI cable then replug everything every time I want to upload a sketch. Is this a hardware problem or something I can solve in software?

    avrdude: stk500_recv(): programmer is not responding

    Using Arduino 1.6 on OSX with a genuine FTDI cable from Sparkfun.

    #2390

    Michael
    Keymaster

    That sounds strange but I can’t imagine that it has anything to do with the backpack hardware. The ATmega328 chip has the same Uno bootloader as any Uno-compatible Arduino.
    Are you certain that your FTDI cable is genuine and not one of the cheap clones that Sparkfun sells? I quit buying them from Sparkfun because they had a 50% failure rate and Sparkfun refused to believe that was a bad thing.

    #2391

    sockbot
    Member

    I managed to resolve this problem by installing the 2.3 VCP drivers from the FTDI website. I no longer need to unplug the cable every time to upload =)

    The native OSX drivers don’t work properly.

    #2393

    Michael
    Keymaster

    Ok that’s good to hear. I use a mac for all development and use the official FTDI driver.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.